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GRADIENTS, BLENDS, 
AND PATTERNS 

 
Lesson overview 
In this lesson, you’ll learn how to do the following: 

• Create and save a gradient fill. 

• Apply and edit a gradient on a stroke. 

• Apply and edit a radial gradient. 

• Add colors to a gradient. 

• Adjust the direction of a gradient. 

• Adjust the opacity of color in a gradient. 

• Blend the shapes of objects in intermediate steps. 

• Create smooth color blends between objects. 

• Modify a blend and its path, shape, and color. 

• Create and paint with patterns. 
 

This lesson takes approximately 60 minutes to complete. Please log in 
to your account on peachpit.com to download the lesson files for this 
chapter, or go to the “Getting Started” section at the beginning of this 
book and follow the instructions under “Accessing the lesson files and 
Web Edition.” 

Your Account page is also where you’ll find any updates to the chapters 
or to the lesson files. Look on the Lesson & Update Files tab to access the 
most  current content. 
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To add texture and interest to your artwork in 
Illustrator, you can apply gradient fills, which are 
graduated blends of two or more colors, patterns, 
and blends of shapes and colors. In this lesson, you’ll 
explore how to work with each of these to complete 
a project. 
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● Note: If you 
have not already 
downloaded the project 
files for this lesson to 
your computer from 
your Account page, 
make sure to do so 
now. See the “Getting 
Started” section at the 
beginning of the book. 

Starting the lesson 
In this lesson, you’ll explore various ways to work with gradients, blend shapes and 
colors, and create and apply patterns. Before you begin, you’ll restore the default 
preferences for Adobe Illustrator CC. Then you’ll open the finished art file for this 
lesson to see what you’ll create. 

1 To ensure that the tools function and the defaults are set exactly as described 
in this lesson, delete or deactivate (by renaming) the Adobe Illustrator CC 
preferences file. See “Restoring default preferences” in the “Getting Started” 
section at the beginning of the book. 

2 Start Adobe Illustrator CC. 

3 Choose File > Open, and open the 
L10_end.ai file in the Lessons > 
Lesson10 folder on your hard  disk. 

4 Choose View > Fit All In Window. If 
you don’t want to leave the document 
open as you work, choose File > Close. 

To begin working, you’ll open an art file 
that you need to finish. 

 
5 Choose File > Open. In the Open dialog 

box, navigate to the Lessons > Lesson10 
folder, and select the L10_start.ai file on 
your hard disk. Click Open to open 
the file. 

6 Choose View > Fit All In Window. 

7 Choose File > Save As, name the file 
Cake.ai, and select the Lessons > 
Lesson10 folder in the Save As menu. 
Leave the Format option set to   Adobe 
Illustrator (ai) (macOS) or the Save As Type option set to Adobe Illustrator 
(*.AI) (Windows) and then click Save. 

8 In the Illustrator Options dialog box, leave the Illustrator options at their default 
settings and then click OK. 

9 Choose Reset Essentials from the workspace switcher in the Application bar. 

● Note: If you don’t see Reset Essentials in the workspace switcher menu, choose Window > 
Workspace > Essentials before choosing Window > Workspace > Reset Essentials. 
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Working with gradients 
A gradient fill is a graduated blend of two or more colors, and it always includes a 
starting color and an ending color. You can create different types of gradient fills 
in Illustrator, including linear, in which the beginning color blends into the ending 
color along a line, and radial, in which the beginning color radiates outward, from 
the center point to the ending color. You can use the gradients provided with Adobe 
Illustrator CC or create your own gradients and save them as swatches for later use. 

 

Linear 
Gradient 

Radial 
Gradient 

 

You can use the Properties panel to access the Gradient panel (Window > 
Gradient) or the Gradient tool ) to apply, create, and modify gradients. In the 
Gradient panel, the Gradient Fill box or Stroke box displays the current gradient 
colors and gradient type applied to the fill or stroke of an object. 

 

A. Gradient 

A I B.    Fill box/ 

J 
Stroke box 

B K 
C.    Reverse Gradient 

C D.   Gradient 

D midpoint 

E M E.    Gradient slider 

F F.    Color stop 
G 

H 

G. Opacity 

H. Location 

I. Gradient type 

J. Stroke gradient 
type 

K. Angle 

L. Aspect ratio 

M. Delete Stop 

● Note: The Gradient 
panel you see won’t 
match the figure, and 
that’s okay. 

 

In the Gradient panel under the gradient slider (labeled “E” in the previous figure), 
the leftmost gradient stop (labeled “F”) is called a color stop. This marks the starting 
color; the right gradient stop marks the ending color. A color stop is the point at 
which a gradient changes from one color to the next. You can add more color stops 
by clicking below the gradient slider, and double-clicking a color stop opens a panel 
where you can choose a color from swatches, or color sliders. 

Applying a linear gradient to a fill 
With the simplest, two-color linear gradient, the starting color (leftmost color 
stop) blends into the ending color (rightmost color stop) along a straight line. To 
begin the lesson, you’ll apply a gradient fill that comes with Illustrator to the green 
background shape. 

1 Using the Selection tool ( ), click to select the large green rectangle in the 
background of the artboard on the left. 
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2   Click the Fill color ( ) in the Properties panel, select the Swatches option 
( ), and select the gradient swatch named “White, Black.” Leave the 
swatches showing. 

 

The default black-and-white gradient is applied to the fill of the selected shape. 
 

Editing a gradient 
Next, you’ll edit the colors in the default black and white gradient you applied. 

1 Click the Fill color in the Properties panel again to show the swatches, if it’s 
not still showing. Click the Gradient Options button in the Swatches panel that 
appears to open the Gradient panel (Window > Gradient), and perform 
the following: 

• Make sure that the Fill box is selected (circled in the figure). 

• Double-click the white, leftmost gradient stop to select the starting color of 
the gradient (an arrow is pointing to it in the figure). 

• Click the Swatches button ( ) in the panel that appears. 

• Click to select the light brown swatch named “BG 10%.” 
 

 

2 Click in a blank area of the Gradient panel to hide the Swatches panel. 
 
 
 

302  LESSON 10   Gradients, Blends, and Patterns 



From the Library of Alvaro Alvarez  

3    In the Gradient panel, perform the following: 

• Double-click the black color stop on the right side of the gradient slider to 
edit the color in the Gradient panel (circled in the figure). In the panel that 
appears, click the Color button (     ) to open the Color panel. 

• Click the menu icon ( ), and choose CMYK from the menu, if CMYK 
values aren’t showing. 

• Change the CMYK values to C=25, M=25, Y=25, and K=0. 

• After entering the last value, click in a blank area of the Gradient panel. 

 
 
 
 
 
 
 
 
 
� Tip: To move 
between text fields, 
press the Tab key. Press 
Enter or Return to apply 
the last value typed. 

 
 
 
 
 
 
 
 
 
 

Saving a gradient 
Next, you’ll save the gradient you just edited as a swatch, in the Swatches panel. 
Saving a gradient is a great way to be able to apply it to other artwork easily and 
maintain consistency in the gradient appearance. 

1 In the Gradient panel, click the 
Gradient menu arrow ( ) to the left of 
the word “Type,” and click the Add To 
Swatches button ( ) at the bottom of 
the panel that appears. 

The Gradient menu you just saw lists all 
the default and saved gradients that you 
can apply. 

2 Click the X at the top of the Gradient panel to close it. 

3 With the background shape still 
selected, click the Fill color box in the 
Properties panel. With the Swatches 
option ( ) selected, double-click the 
“New Gradient Swatch 1” thumbnail to 
open the Swatch Options dialog box. 

 
 
 
 
 
 
 
� Tip: Like most things 
in Illustrator, there is 
more than one method 
for saving a gradient 
swatch. You can also 
save a gradient by 
selecting an object 
with a gradient fill or 
stroke, clicking the Fill 
box or Stroke box in 
the Swatches panel 
(whichever the gradient 
is applied to), and 
then clicking the New 
Swatch button ) at 
the bottom of the 
Swatches panel. 
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� Tip: You can 
hide the gradient 
annotator (bar) by 
choosing View > Hide 
Gradient Annotator. 
To show it again, 
choose View > Show 
Gradient Annotator. 

4 In the Swatch Options dialog box, type Background in the Swatch Name field 
and then click OK. 

5 Click the Show Swatch Kinds Menu 
button ( ) at the bottom of the 
Swatches panel, and choose Show 
Gradient Swatches from the menu to 
display only gradient swatches in the 
Swatches panel. 

The Swatches panel lets you sort colors 
based on type, like gradient swatches. 

6 With the rectangle still selected on the 
artboard, apply some of the different gradients to the shape fill by selecting 
them in the Swatches panel. 

7 Click the gradient named “Background” (the one you just saved) in the Swatches 
panel to make sure it’s applied before continuing to the next step. 

8 Click the Show Swatch Kinds Menu button ( ) at the bottom of the Swatches 
panel, and choose Show All Swatches from the menu. 

9 Choose File > Save, and leave the rectangle selected. 
 
Adjusting a linear gradient fill 
Once you have painted an object with a gradient, you can adjust the direction, the 
origin, and the beginning and end points of the gradient applied to the artwork, 
using the Gradient tool. Now you’ll adjust the gradient fill in the background shape. 

1 With the Selection tool ( ) selected, double-click the background shape to 
isolate it. 

This is a great way to enter Isolation mode for a single shape so you can focus 
on it without the other content (in this case) on top of it. 

2 Choose View > Zoom Out. 

3 Select the Gradient tool ) in the Tools panel. 

With the Gradient tool, you can apply a gradient 
to the fill of an object or edit an existing gradient 
fill. Notice the horizontal gradient annotator 
(bar) that appears in the middle of the rectangle, 
which indicates the direction of the gradient. The 
larger circle on the left shows the starting point 
of the gradient (the first color stop), and the 
smaller square on the right is the ending point 
(the last color stop). 
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4 Move the pointer over the bar in the 
gradient annotator. 

The bar turns into the gradient slider, much 
like the one found in the Gradient panel. You 
can use the gradient slider on the art to edit the 
gradient without opening the Gradient panel. 

5 With the Gradient tool selected, pressing the 
Shift key, drag from the top of the artboard 
down to the bottom of the artboard to change 
the position and direction of the starting and 
ending colors of the gradient in the rectangle. Release the mouse button and 
then release the key. 

● Note:  If you 
move the pointer to 
different areas of the 
gradient slider, the 
appearance of the 
pointer may change. 
This indicates that 
different functionality 
has been activated. 

 
● Note:  Holding 
down the Shift key 
constrains the gradient 
to 45-degree angles. 

 

  
 

6 With the Gradient tool, move the pointer just off the small white square at the 
bottom of the gradient annotator. A rotation icon ( ) appears. Drag to the right 
to rotate the gradient in the rectangle and then release the mouse button. 

 

 

7 Double-click the Gradient tool in the Tools panel to 
open the Gradient panel. Ensure that the Fill box is 
selected in the panel (circled in the figure) and then 
choose –60 from the Angle menu. 

8 Choose Object > Lock > Selection to lock the rectangle 
so you don’t accidentally move it later and to make 
selecting other artwork easier. 

● Note: Entering the 
gradient rotation in 
the Gradient panel, 
rather than adjusting it 
directly on the artboard, 
is useful when you want 
to achieve consistency 
and precision. 
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● Note: Depending 
on the resolution of 
your screen, you may 
see a single-column 
Tools panel. 

 
● Note: The Color 
panel group may open. 
If it does, you can 
close it. 

9 Select the Selection tool, and press Esc to exit Isolation mode. You should see all 
of the artwork again. 

10 Choose File > Save. 
 
Applying a linear gradient to a stroke 
You can also apply a gradient blend to the stroke of an object. Unlike a gradient 
applied to the fill of an object, you cannot use the Gradient tool to edit a gradient on 
the stroke of an object. A gradient on a stroke, however, has more options available 
in the Gradient panel than a gradient fill. Next, you will add a series of colors to a 
stroke gradient to create a frame for the artwork. 

1 With the Selection tool ( ) selected, click the red stroke of the shape around 
the cake to select that shape. 

2 Click the Stroke box at the bottom of the Tools panel, and click the Gradient 
box below the Fill box to apply the last used gradient. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Note: You can apply 
a gradient to a stroke 
in three ways: within 
a stroke (default) (    ), 
along a stroke ( ), and 
across a stroke (     ). 

3 Select the Zoom tool ( ) in the Tools panel, and drag across the stroke of the 
selected shape to zoom in to it. Select the Selection tool. 

Editing a gradient on a stroke 
For a gradient on a stroke, you can choose how to align the gradient to the stroke: 
within, along, or across. In this section, you’ll explore how to align a gradient to the 
stroke and also edit the colors of the gradient. 

1 In the Gradient panel, click the Stroke 
box (if not already selected; it’s circled 
in the figure) to edit the gradient 
applied to the stroke. Leave Type as 
Linear, and click the Apply Gradient 
Across Stroke button ( ) to change 
the gradient type. 
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Next, you’ll add colors to the gradient using a few methods. 

2 Position the pointer below the gradient slider, between the two color stops. 
When the pointer with a plus sign ( ) appears, click to add another color stop 
like you see in the middle part of the following figure. 

 

 

3 Double-click that new color stop and, 
with the swatches selected ( ), click 
the swatch named “BG 10%.” Press the 
Escape key to hide the swatches and 
return to the Gradient panel. 

 
 
 

4 With the color stop still selected, 
change Location to 50%. 

For the next few steps, you’ll discover 
how to add a new color to the gradient 
by dragging to create a copy of a color 
stop in the Gradient panel. 

 
5 Pressing the Option (macOS) or Alt 

(Windows) key, drag the color stop 
on the far right to the left; release the 
mouse button when you see roughly 
25% in the Location value and then 
release the modifier key. 

There are now four color stops. Next 
you’ll see how to remove a color stop. 
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6 Drag the color stop on the far left down, away from the gradient slider. When 
you see that it’s gone from the slider, release the mouse to remove it. 

 

7 Click the X at the top of the Gradient panel to close it. 
 

Applying a radial gradient to artwork 
As previously noted, with a radial gradient, the starting color (leftmost color stop) 
of the gradient defines the center point of the fill, which radiates outward to the 
ending color (rightmost color stop). Next, you’ll create and apply a radial gradient 
fill to a shape to make a shadow underneath the cake. 

1 Choose View > Fit Artboard In Window. 

2 With the Selection tool (  ) selected, click the orange ellipse. 

3 Press Command++ (macOS) or Ctrl++ (Windows) a few times to zoom in. 

4 Change the fill color to the White, Black gradient in the Properties panel. Leave 
the Swatches panel showing. 

 

5 Click the Gradient Options button in the Swatches panel to open the Gradient 
panel. In the Gradient panel, make sure the Fill box is selected. Choose Radial 
from the Type menu to convert the linear gradient to a radial gradient. 
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Editing the colors in the radial gradient 
Previously in this lesson, you edited gradient colors in the Gradient panel. You    
can also edit the colors in a gradient using the Gradient tool, which is what you’ll   
do next. 

1 In the Gradient panel, with the ellipse still selected, click the Reverse Gradient 
button ( ) to swap the white and black colors in the gradient. 

 

2 Select the Gradient tool ) in the Tools panel. 

3 Position the pointer over the gradient annotator (bar) in the ellipse to reveal the 
gradient slider, and perform the following: 

• Double-click the black color stop in the center of the ellipse to edit the color. 

• In the panel that appears, click the Swatches button ( ), if it’s not 
already selected. 

• Select the swatch named “Radial 1.” 
 

Notice that the gradient annotator starts from the center of the ellipse and 
points to the right. The dashed circle around the gradient annotator when the 
pointer is over it indicates that it is a radial gradient. You can set additional 
options for radial gradients, as you’ll soon see. 

4 Press Escape to hide the panel. 

5 Position the pointer beneath the gradient slider, in the middle. When the 
pointer with a plus sign ( ) appears, click to add another color to the gradient 
(see the first part of the following figure). 
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� Tip: When you edit a 
color stop that has a 
swatch applied, you can 
easily see which swatch 
is applied because 
it is highlighted in 
the panel. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● Note: You may not 
see the dotted circle 
as you drag the end of 
the gradient annotator. 
That’s okay. It appears if 
you position the pointer 
over the gradient 
annotator bar first, 
before dragging the 
right end point. 

6 Double-click the new color stop. In the panel that appears, click the Swatches 
button ( ), and select the swatch named “Radial 2.” Change Location 
to 45%. Press Enter or Return to change the value and hide the panel. 

 

7 Choose File > Save. 
 
Adjusting the radial gradient 
Next, you’ll change the aspect ratio of the radial gradient and change the radius and 
the origin of the radial gradient. 

1 With the Gradient tool ) selected and the ellipse still selected, move the 
pointer over the right end of the gradient annotator (see the first part of the 
following figure). When the pointer changes ( ), drag to the right, stopping at 
the right edge of the ellipse shape, and release the mouse button to lengthen 
the gradient. 

 
 
 
 
� Tip: You can also 
drag the gradient 
slider to reposition the 
gradient in the ellipse. 

2 In the Gradient panel, ensure that the Fill box is selected and then change the 
Aspect Ratio ( ) to 30% by selecting it from the menu. Leave the panel open. 

 

� Tip: You can drag 
the small white dot 
to the left of the 
larger white dot to 
reposition the center 
of the gradient without 
moving the entire 
gradient bar. This also 
changes the radius of 
the gradient. 
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The aspect ratio changes a radial gradient into an elliptical gradient and makes 
the gradient better match the shape of the artwork. Another way to edit the 
aspect ratio is to do so visually. If you position the pointer over the gradient 
on the selected artwork with the Gradient tool selected and then position the 
pointer over the top black circle that appears on the dotted path, the pointer 
changes to    . You can then drag to change the aspect ratio of the gradient. 

3 Select the Selection tool ( ) in the Tools panel, and double-click the Scale tool 
( ) in the Tools panel. Change the Uniform Scale value to 80%, and click OK. 

● Note: The aspect 
ratio is a value between 
0.5% and 32,767%. As 
the aspect ratio gets 
smaller, the ellipse 
flattens and widens. 

 

  

If you transform a shape with a gradient applied, such as scaling or rotating the 
shape (among other types of transformations), the gradient transforms as well. 
By the way, double-clicking the Scale tool, like other Transform tools, is the 
same as choosing Object > Transform > Scale (in this case). 

4 Choose Select > Deselect and then choose File > Save. 
 
Applying gradients to multiple objects 
You can apply a gradient to multiple objects by selecting all the objects, applying 
a gradient color, and then dragging across the objects with the Gradient tool. 

Now you’ll apply a linear gradient fill to the two shapes that make up the cake. 

1 Choose View > Fit Artboard In Window. 

2 With the Selection tool ( ) selected, click the cream-colored cake shape and, 
pressing the Shift key, click the other cake shape to select both. 

3 Click the Fill color in the Properties panel. In the panel that appears, make sure 
the Swatches option ( ) is selected, and select the Background gradient swatch. 
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4 Select the Gradient tool ) in the Tools panel. Choose View > Hide Gradient 
Annotator so the bars that appear in the shapes are temporarily  hidden. 

5 Drag from the middle of the upper shape to the bottom shape. Leave the 
shapes selected. 

 

Dragging across multiple shapes with the Gradient tool allows you to apply a 
gradient across the shapes. 

Adding transparency to gradients 
By specifying varying opacity values for the different color stops in your gradient, 
you can create gradients that fade in or out and that show or hide underlying 
artwork. Next, you’ll apply a gradient that fades to transparent on the cake shapes. 
To do that, you’ll copy the cake shapes and apply a gradient to the copies. 

1 Select the Selection tool ( ). With the cake shapes still selected, choose Edit > 
Copy and then choose Edit > Paste In Front. 

2 Choose Object > Arrange > Bring To Front to 
bring them on top of the other cake shapes. 

 
 
 
 
 
 

3 In the Gradient panel, 
ensure that the Fill box is 
selected. Click the Gradient 
menu arrow ( ) and then 
select White, Black to 
apply the generic gradient to 
the fill. 
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4 Click the Reverse Gradient button ( ) in the Gradient panel so the gradient 
starts with black (black will be the color stop on the left of the gradient slider). 

 

5 Select the Gradient tool ) in the Tools panel, and drag from the left edge of 
the widest cake shape to the right, going to the middle of the shapes. 

 

6 In the Gradient panel, click the black color stop in the Gradient panel. Change 
Opacity to 40% Click the white color stop and change Opacity to 0%. 

   
7 Drag the gradient midpoint (the diamond shape) to the right until you see a 

value of approximately 60% in the Location field. 
 

8 Choose Object > Hide >  Selection. 

9 Choose File > Save. 
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Working with blended objects 
You can blend two distinct objects to create and distribute shapes evenly between 
two objects. The two shapes you blend can be the same or different. You can also 
blend between two open paths to create a smooth transition of color between 
objects, or you can combine blends of colors and objects to create color transitions 
in the shape of a particular object. 

The following are examples of different types of blended objects you can create: 
 

Blend between two of 
the same shape. 

Blend between two of the same 
shape, each with a different color fill. 

 
Blend between two 

different shapes with 
different fill colors. 

 
Blend between two of the 
same shape along a path. 

 
 

Smooth color blend between 
two stroked lines (original lines 

on left, blend on right). 

 
 
 
 
 
 
 
 
 
 
 
 
� Tip: You can 
add more than two 
objects to a blend. 

 
● Note: If you wanted 
to end the current 
path and blend other 
objects, you would first 
click the Blend tool in 
the Tools panel and 
then click the other 
objects, one at a time, 
to blend them. 

When you create a blend, the blended objects are treated as one object, called a 
blend object. If you move one of the original objects or edit the anchor points of the 
original object, the blend changes accordingly. You can also expand the blend to 
divide it into distinct objects. 

Creating a blend with specified steps 
Next, you’ll use the Blend tool ) to blend two shapes that you will use to create 
a pattern for the cake decoration. 

1 Choose View > Zoom In a few times to zoom in closely. Make sure you can still 
see the two small maroon shapes on the cake (see the following figure). 

2 Select the Blend tool ) in the Tools panel. Move the little box part of the 
pointer ( ) over the center of the small maroon shape on the left side of the 
cake and click. 

3 Move the pointer away from the shape and a you’ll see a plus sign next to the 
pointer (    ), indicating that you can add an object to the blend. Move the 
little box part of the pointer (not the plus) over the center of the small maroon 
shape on the right side of the cake and click to create a blend between these 
two objects. 
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4    With the blended object still selected, choose Object > Blend > Blend Options. 
In the Blend Options dialog box, choose Specified Steps from the Spacing menu, 
change Specified Steps to 9, and then click OK. 

� Tip: To edit the 
blend options for an 
object, you can also 
select the blend object 
and then double-click 
the Blend tool. You 
can also double-click 
the Blend tool ) 
in the Tools panel to set 
tool options before you 
create the blend object. 

 
 
 

Modifying a blend 
Now you’ll edit the spine of the blend you just created so the shapes blend along 
a curve. 

1 Select the Selection tool ( ) in the Tools panel, and click anywhere on the blend 
object to select it, if it’s not already selected. Choose View > Zoom In, making 
sure you can still see the whole blend object. 

2 Double-click anywhere on the blend object to enter Isolation mode. 

This temporarily ungroups the blended objects and lets you edit each original 
shape, as well as the spine. The spine is a path along which the steps in a 
blended object are aligned. By default, the spine is a straight line. 

3 Choose View > Outline. 

In Outline mode, you can see the outlines of the two original shapes and a 
straight path (spine) between them. These three objects are what a blend object 
is composed of, by default. It can be easier to edit the path between the original 
objects in Outline mode. 
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4 Click and drag the edge of the smaller shape on the right up until it touches the 
cake decoration above it. See the following figure. 

 

 

 
 
 
 
� Tip: Another way to 
reshape the spine of a 
blend is to blend the 
shapes along another 
path. You can draw 
another path, select 
the blend as well, and 
then choose Object > 
Blend > Replace Spine. 

Make sure you drag the shape and not the path between the shapes. 

5 Choose Select > Deselect, and remain in Isolation mode. 

6 Select the Pen tool ( ) in the Tools panel. Press the Option key (macOS) or Alt 
key (Windows), and position the pointer over the path between the shapes. When 
the pointer changes (  ), drag the path up, like in the first part of the figure. 

 
 
� Tip:   If the maroon shapes 
don’t align with the 
points on the cake 
shape above, you can 
press the arrow keys 
(left or right) after 
dragging with the Pen 
tool to reshape the 
path. You can also press 
the Option/Alt key with 
Pen tool selected, and 
drag the path again. 

7 Choose View > GPU Preview if supported, or View > Preview On CPU (Preview)  
if not, to see the  change. 

 

8 Press Esc to exit Isolation mode. 

9 Choose Select > Deselect, and choose File >  Save. 
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Creating and editing a smooth color blend 

You can choose several options for blending 
the shapes and colors of objects to create a new 
object. When you choose the Smooth Color 
blend option in the Blend Options dialog box, 
Illustrator combines the shapes and colors of the objects into many intermediate 
steps, creating a smooth, graduated blend between the original objects, like you see 
in the figure on the right. 

If objects are filled or stroked with different colors, the steps are calculated to 
provide the optimum number of steps for a smooth color transition. If the objects 
contain identical colors or if they contain gradients or patterns, the number of steps 
is based on the longest distance between the bounding box edges of the two objects. 

Now you’ll combine two shapes into a smooth color blend to make the trunk of a tree 
that is the leg of the cake stand. 

1 Choose View > Fit Artboard In Window. 

2 Select the Zoom tool ( ), and drag across the paths under the cake. 

Both brown paths have a stroke color and no fill. Objects that have strokes 
blend differently than those that have no stroke. 

3 Select the Selection tool ( ) and click on the path on the left. Press the Shift key 
and click on the path on the right to select both. 

4 Choose Object > Blend >  Make. 

This is another way to create a blend and can be useful if creating a blend 
using the Blend tool proves challenging. The blend you created is using the last 
settings from the Blend Options dialog box (Specified Steps: 9). 

Next, you’ll change the blend settings for the tree trunk so that it blends as 
smooth color, rather than in specified steps. 
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5 With the blend object still selected, double-click the Blend tool ( ) in the 
Tools panel. In the Blend Options dialog box, choose Smooth Color from the 
Spacing menu to set up the blend options, which will remain set until you 
change them. Select Preview and then click OK. 

 

 
 
● Note: Creating 
smooth color blends 
between paths can 
be difficult in certain 
situations. For instance, 
if the lines intersect or 
the lines are too curved, 
unexpected results 
can occur. 

6 Choose Select > Deselect. 

Once you’ve applied a smooth color blend to objects, you can edit it. Next, you’ll 
edit the paths that make up the blend. 

7 With the Selection tool (   ) selected, double-click within the color blend to 
enter Isolation mode. Click the path on the left to select it, and change the 
Stroke color in the Properties panel to any color you want. Press the Escape key 
to hide the panel. Notice how the colors are blended. 

 

� Tip: If you’re having a 
hard time selecting the 
path, choose 
View > Outline to enter 
Outline mode. Select 
the path, and then 
choose View > GPU 
Preview if supported or 
View > Preview On CPU 
(Preview) if not. 

 
 
 
 
 
 

8 Choose Edit > Undo Apply Swatch until the original stroke color is showing. 

9 Double-click away from the blend to exit Isolation mode, and deselect all. 

10 Choose View > Fit Artboard In Window. 

11 Choose File > Save. 
 
 
 
 
 
 
 
 
 
 

318  LESSON 10   Gradients, Blends, and Patterns 



From the Library of Alvaro Alvarez  

Painting with patterns 
In addition to process colors, spot colors, and gradients, the Swatches panel can 
also contain pattern swatches. Illustrator provides sample swatches of each type 
in the default Swatches panel as separate libraries and lets you create your own 
patterns and gradients. In this section, you will focus on creating, applying, and 
editing patterns. 

Applying an existing pattern 
A pattern is artwork saved in the Swatches panel that can be applied to the stroke 
or fill of an object. You can customize existing patterns and design patterns from 
scratch with any of the Illustrator tools. All patterns start with a single tile that is 
tiled (repeated) within a shape, starting at the ruler origin and continuing to the 
right. Next, you will apply an existing pattern to a shape. 

1 Choose Object > Unlock All. 

2 Choose Select > Deselect. 

3 With the Selection tool ( ) selected, click to select the background rectangle 
behind all of the other artwork. 

4 Click More Options ( ) in the Appearance 
section of the Properties panel to open the 
Appearance panel (or choose Window > 
Appearance). Click the Add New Fill button at the 
bottom of the panel. This adds a second gradient fill 
to the rectangle and layers it on top of the first. 

 
5 In the Appearance panel, click 

the top fill box to the right of the 
word “Fill” to show a panel of 
swatches. An arrow is pointing 
to it in the figure. Select the 
Pompadour swatch. 

The pattern swatch fills the shape 
as a second fill on top of the first. 
The swatch named “Pompadour” is 
included in the swatches for a Print 
document. You can find so many 
more pattern swatches in Illustrator 
by choosing Window > Swatch Libraries > Patterns and choosing a 
pattern library. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Note: You’ll learn all 
about the Appearance 
panel in Lesson 12, 
“Exploring Creative 
Uses of Effects and 
Graphic Styles.” 
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● Note:  You don’t 
need to have anything 
selected when you 
create a pattern. You 
can add content to the 
pattern when you edit it 
in Pattern Editing mode, 
as you’ll see. 

6 In the Appearance panel, click 
the arrow to the left of the top 
word “Fill.” Click the word 
“Opacity” that appears to open the 
Transparency panel (or choose 
Window > Transparency). Change 
the Opacity value to 20. Press the 
Escape key to hide the panel. 

7 Close the Appearance panel. 

8 Choose Object > Lock > Selection 
and then choose File > Save. 

Creating your own pattern 
In this section, you’ll create your own custom pattern. Patterns you create are saved 
as a swatch in the Swatches panel for the document you’re working in. 

1 With nothing selected, click the Next Artboard 
button in the Properties panel to show the smaller 
artboard on the right. 

2 With the Selection tool ( ) selected, choose 
Select > All On Active Artboard to select the 
artwork you’ll use to create a pattern. 

3 Choose Object > Pattern > Make. Click OK in the 
dialog box that appears. 

 
 
 
 
 

When you create a pattern, Illustrator enters Pattern Editing mode, which is 
similar to the Isolation mode you’ve worked with in previous lessons. Pattern 
Editing mode allows you to create and edit patterns interactively, while 
previewing the changes to the pattern on the artboard. All other artwork is 
dimmed and cannot be edited while in this mode. The Pattern Options panel 
(Window > Pattern Options) also opens, giving you all the necessary options to 
create your pattern. 
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4 Choose Select > All On Active Artboard to select the artwork. 

5 Press Command++ (macOS) or Ctrl++ (Windows) to zoom in. 

The series of lighter-colored objects around the artwork in the center are the 
pattern repeat. They are there for a preview and are a little dimmed to let you 
focus on the original. The blue box around the original group of objects is the 
pattern tile (the area that repeats). 

6 In the Pattern Options panel, change the 
Name to Cake Top, and try choosing 
different options from the Tile Type 
menu to see the effect on the pattern. 
Before continuing, make sure Grid 
is selected. 

The name in the Pattern Options panel 
becomes the name of the swatch saved 
in the Swatches panel and can be useful 
to distinguish multiple versions of a 
pattern swatch, for instance. Tile Type 
determines how the pattern is tiled. You have three main Tile Type choices: the 
default grid pattern, a brick-style pattern, or the hex pattern. 

7 Choose 1 x 1 from the Copies menu at the bottom of the Pattern Options panel. 
This will remove the repeat and let you temporarily focus on the main 
pattern artwork. 

8 Click in a blank area to deselect the artwork. 

9 Option+Shift-drag (macOS) or Alt+Shift-drag (Windows) the blue circle in the 
center to a little outside the upper-right corner of the blue pattern tile  box. 

● Note: A pattern can 
be composed of shapes, 
symbols, or embedded 
raster images, among 
other objects that you 
can add in Pattern 
Editing mode. For 
instance, to create a 
flannel pattern for a 
shirt, you can create 
three overlapping 
rectangles or lines, 
each with varying 
appearance options. 
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� Tip: The H Spacing and V 
Spacing values can be 
either positive or 
negative values, and 
they move the tiles 
apart or bring them 
closer together, either 
horizontally (H) or 
vertically (V). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● Note:   To learn 
more about the Pattern 
Options panel, search 
for “Create 
and edit patterns” 
in Illustrator Help 
(Help > Illustrator Help). 

 
� Tip: If you want to 
create pattern 
variations, you can click 
Save A Copy in the bar 
along the top of the 
Document window 
when in Pattern Editing 
mode. This saves the 
current pattern in the 
Swatches panel as a 
copy and allows you to 
continue creating. 

10 In the Pattern Options panel, change the following options: 

• Choose 5 x 5 from the Copies menu to see the 
repeat again. 

Notice that the circle you dragged outside of the 
pattern tile is not repeated. That’s because it’s not 
within the pattern tile. Only artwork within the 
pattern tile is repeated. 

 

• Select the Size Tile To Art option in 
the Pattern Options panel. 

The Size Tile To Art selection fits the 
tile area (the blue square) to the bounds 
of the artwork, changing the spacing 
between the repeated objects. With  
Size Tile To Art deselected, you could 
manually change the width and the 
height of the pattern definition area in 
the Width and Height fields to include 
more content or to edit the spacing 
between. You can also edit the tile area manually with the Pattern Tile Tool 
button ( ) in the upper-left corner of the Pattern Options panel. 

If you set the spacing values (H Spacing or V Spacing) to negative values, 
the artwork in the pattern tile will overlap. By default, when objects overlap 
horizontally, the left object is on top; when objects overlap vertically, the top 
object is on top. You can set the overlap values: Left In Front, Right In Front 
to change overlap horizontally or Top In Front, Bottom In Front to change the 
overlap vertically. 

11 Click Done in the bar along the top of 
the Document window. If a dialog box 
appears, click OK. 

12 Choose File > Save. 
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Applying your pattern 
You can assign a pattern using a number of different methods. In this section, you’ll 
apply your pattern using the fill color in the Properties panel. 

1 With nothing selected, click the Previous Artboard button ( ) in the Properties 
panel to show the larger artboard on the left. 

2 With the Selection tool ( ), click the top cake shape (see the following figure). 
Choose Edit > Copy and then Edit > Paste In Front. 

3 Select the swatch named “Cake Top” from the fill color in the Properties panel. 

 
 
 
 
 
 
 
 
 
 
 
● Note: Instead of 
making a copy of the 
shape, you could have 
applied a second fill 
to the shape like you 
did previously. 

 
 
 
 
 

Editing your pattern 
Next, you’ll edit the Cake Top pattern swatch in Pattern Editing mode. 

1 With the shape still selected, click the Fill color in the Properties panel. Double- 
click the Cake Top pattern swatch to edit it in Pattern Editing mode. 

2 Press Command++ (macOS) or Ctrl++ (Windows) several times to zoom in. 

3 In Pattern Editing mode, with the Selection tool ( ) selected, click one of the 
blue circles; then pressing the Shift key, click to select the other. 

4 In the Properties panel, change the fill color to the brown swatch named “BG.” 
 

5 Click Done in the gray bar along the top of the Document window to exit 
Pattern Editing mode. 

6 Choose View > Fit Artboard In Window. 

7 Click the top cake shape with the pattern fill to select it, if necessary. 
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� Tip: In the Scale 
dialog box, if you 
wanted to scale 
the pattern and the 
shape, you can select 
Transform Objects 
and select Transform 
Patterns. You can 
also transform 
patterns in the 
Transform panel 
(Window > Transform) 
by choosing Transform 
Pattern Only, Transform 
Object Only, or 
Transform Both from 
the panel menu 
( ) before applying a 
transformation. 

8 With the shape selected, double-click the 
Scale tool ( ) in the Tools panel to scale 
the pattern but not the shape. In the Scale 
dialog box, change the following options 
(if not already set): 

• Uniform Scale: 50% 
• Scale Corners: Deselected (the default 

setting) 
• Scale Strokes & Effects: Deselected 

(the default setting) 
• Transform Objects: Deselected 
• Transform Patterns: Selected 

9 Select Preview to see the change. 
Click OK. 

10 Choose Object > Show All. 

11 Choose Select > Deselect and then choose 
File > Save. 

12 Choose File > Close. 
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